Урок 23-24. Процедуры с параметрами. Процедуры с несколькими параметрами - Каталог статей - Урок по информатике
Воскресенье, 26.03.2017, 21:52
План-конспекты уроков по информатике
0+ Главная Регистрация Вход
Приветствую Вас, Гость · RSS
Меню сайта
Категории раздела
Все [56]
logoWriter [19]
Уроки по теме "logoWriter"
CorelDraw [7]
Практические задания с пошаговым алгоритмом выполнения по теме "CorelDraw"
MacromediaFlash [0]
Практические работы по теме "MacromediaFlash"
MS Excel [7]
План-конспекты по теме "MS Excel"
Логика [10]
План-конспекты уроков по логике
Разное [10]
Уроки, которые не подходят ни в одну категорию
Pascal [7]
Форма входа
Статистика

Яндекс.Метрика

Онлайн всего: 1
Гостей: 1
Пользователей: 0
Наш опрос
Очень сложно найти конспект на тему...
Всего ответов: 628
Реклама
 Каталог статей
Главная » Уроки » Все

Урок 23-24. Процедуры с параметрами. Процедуры с несколькими параметрами

Тема урока: «Процедуры с параметрами»

Цели урока:
1) закрепить материал по процедурам с параметрами, пройденный на прошлом уроке, на решении конкретных задач;
2) способствовать развитию логического мышления;
3) способствовать воспитанию у ребят внимательности и аккуратности при работе за ПК.
Ход урока
Организационный момент.
Проверка домашних работ учащихся за ПК.
Закрепление темы:
1 задание - нарисовать ёлочку
Решение:
это треугольник :x
пр 30 повтори 3 [вп :x пр 120] вп :x
конец
это движение :x
лв 150 вп :x / 2 - 2,5
конец
иг треугольник 20 движение 20 треугольник 15 движение 15 треугольник 10 движение 10.
Домашнее задание: доделать задачу.

Тема урока: «Процедуры с несколькими параметрами»

Цели урока:
1) на примере конкретных задач познакомить учащихся с новым материалом;
2) способствовать развитию логического мышления, грамотной речи;
3) способствовать воспитанию у ребят внимательности и аккуратности при работе за ПК.
Ход урока
Организационный момент.
Проверка домашних работ учащихся за ПК.
В процедуре может быть несколько параметров, например процедура рисования правильных многоугольников:
это многоугольник
повтори 18 [вп 6 пр 20]
конец
это многоугольник1 :n :x
повтори :n [вп :x пр 360 / :n]
конец
Изменяя первый параметр, можно получать различные правильные фигуры - треугольники, квадраты, … А при изменении второго параметра - размеры фигур.
Задача.
Нарисовать шахматную доску, воспользовавшись процедурой с двумя параметрами: размер клетки и цвет.
повтори 18 [вп 6 пр 20]
конец

Категория: Все | Добавил: Казначей (11.05.2011)
Просмотров: 6988 | Комментарии: 1 | Теги: процедуры в лого, Процедуры с несколькими параметрами | Рейтинг: 1.0/1
Не забываем комментировать!!!

Другие материалы
Арифметика в двоичной системе счисления.
Урок 11. Вычисления в системе LogoWriter
Информация: определение, свойства, формы представл...
Урок 5: Построение изображений в цвете
Практическая работа №4: Редактирование сегментов
План урока для 7 класса "Оператор ввода"
Моделирование и формализация. Часть 1.
Алгоритм и его свойства
Понятие формализации. Часть 2.
Тема 8. Решение логических задач.
Тема 7. Перевод и запись различных выражений с ест...
Урок 18, 19. Понятие переменной. Вычисление значен...

Всего комментариев: 1
1  
Now I feel stupid. That's celeard it up for me

Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Copyright KUPI © 2017
Готовимся к ЕГЭ и ГИА
ГИА, ЕГЭ 2014 по информатике ФИПИ скачать бесплатно без смс
Отследи свою посылку
Друзья сайта
  • Софт бесплатно
  • Интернет магазин бесплатно
  • Наша ссылка
    Наша кнопка
    Конспекты уроков
    Лидеры по просмотрам
    Тема 8. Решение логических задач.
    Виды и типы современных языков программирования
    Алгоритм и его свойства
    Информация: определение, свойства, формы представления; информационные процессы.
    Относительная и абсолютная адресация
    Тема 7. Перевод и запись различных выражений с естественного языка на язык алгебры логики.
    Моделирование и формализация. Часть 1.
    Графика в Турбо Паскаль.
    Сортировка и фильтрация данных в MS Excel
    Понятие формализации. Часть 2.
    Загрузить файл
    Сделать бесплатный сайт с uCoz