Вторник, 25.04.2017, 15:29
План-конспекты уроков по информатике
0+ Главная Регистрация Вход
Приветствую Вас, Гость · RSS
Меню сайта
Категории раздела
Все [56]
logoWriter [19]
Уроки по теме "logoWriter"
CorelDraw [7]
Практические задания с пошаговым алгоритмом выполнения по теме "CorelDraw"
MacromediaFlash [0]
Практические работы по теме "MacromediaFlash"
MS Excel [7]
План-конспекты по теме "MS Excel"
Логика [10]
План-конспекты уроков по логике
Разное [10]
Уроки, которые не подходят ни в одну категорию
Pascal [7]
Форма входа
Статистика

Яндекс.Метрика

Онлайн всего: 1
Гостей: 1
Пользователей: 0
Наш опрос
Очень сложно найти конспект на тему...
Всего ответов: 630
Реклама
 Каталог статей
Главная » Уроки » Все

Урок 22. Процедуры с параметрами в Logo Writer

Тема урока: «Процедуры с параметрами»

Цели урока:
1) познакомить учащихся с понятием "процедура с параметром";
2) способствовать развитию логического мышления;
3) способствовать воспитанию у ребят внимательности и аккуратности при работе за ПК.
Ход урока
Организационный момент.
Проверка домашних работ учащихся.
Задача №1.
Написать программу для рисования следующей фигуры:
подпрограммы в Logo Writer
1 способ)
это кв1
повтори 4 [вп 10 пр 90]
конец
это кв2
повтори 4 [вп 20 пр 90]
конец
…………
иг кв1 кв2 кв3 кв4 сч
2 способ)
это кв :x
повтори 4 [вп :x пр 90]
конец
иг кв 10 кв 20 кв 30 кв 40 сч
Какой из представленных способов (1 - вый или 2 - ой) вы считаете рациональным, предпочтительным?
Почему?
Добавьте в программу команды, отвечающие за цвет каждого квадрата.
Задача №2.
Нарисуйте бабочку
Бабочка в черепашке
это кр1 :x
повтори 360[вп :x пр 1]
конец
это кр2 :y
повтори 360[вп :y лв 1]
конец
иг нц 1 кр1 0,2 нц 2 кр1 0,4 нц 3 кр1 0,6 нц 4 кр1 0,8
нц 1 кр2 0,2 нц 2 кр2 0,4 нц 3 кр2 0,6 нц 4 кр2 0,8
Домашнее задание: доделать задачу №2.
(2 - ой способ
это кр1 :x :c
нц :c повтори 360[вп :x пр 1]
конец
это кр2 :y :c
нц :c повтори 360[вп :y лв 1]
конец
иг кр1 0,2 1 кр1 0,4 2 кр1 0,6 3 кр1 0,8 4
кр2 0,2 1 кр2 0,4 2 кр2 0,6 3 кр2 0,8 4)

Категория: Все | Добавил: Казначей (11.05.2011)
Просмотров: 5831 | Комментарии: 4 | Теги: подпрограммы с параметрами, Процедуры с параметрами в Logo Writ, черепашка и процедуры | Рейтинг: 4.3/3
Не забываем комментировать!!!

Другие материалы
Урок 5: Построение изображений в цвете
Конспекты по языку программирования Паскаль
Урок 10: Работа с листом форм в среде LogoWriter
Тема 3. Таблица истинности.
Тема 7. Перевод и запись различных выражений с ест...
Урок 23-24. Процедуры с параметрами. Процедуры с н...
Понятие формализации. Часть 2.
Тема 8. Решение логических задач.
Тема 1. История логики. Понятие о логике как науке...
Графика в Турбо Паскаль.
Занятие1.2: Структура электронной таблицы. Адреса...
Урок 6: Построение изображений в цвете

Всего комментариев: 4
4  
Qwerty pi'pupse tike layro's like!!! Nuo contre dane lem's pas?

3  
Erty kets mi'sou musice's hve and trix'os biu-biu bong. cry Loabing procer you j'e ves lakture!... angry cry angry angry angry angry

2  
Vauyyy...eeeemm... surprised

1  
A few years ago I'd have to pay seomnoe for this information.

Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Copyright KUPI © 2017
Готовимся к ЕГЭ и ГИА
ГИА, ЕГЭ 2014 по информатике ФИПИ скачать бесплатно без смс
Отследи свою посылку
Друзья сайта
  • Софт бесплатно
  • Интернет магазин бесплатно
  • Наша ссылка
    Наша кнопка
    Конспекты уроков
    Лидеры по просмотрам
    Тема 8. Решение логических задач.
    Виды и типы современных языков программирования
    Алгоритм и его свойства
    Информация: определение, свойства, формы представления; информационные процессы.
    Относительная и абсолютная адресация
    Тема 7. Перевод и запись различных выражений с естественного языка на язык алгебры логики.
    Моделирование и формализация. Часть 1.
    Графика в Турбо Паскаль.
    Сортировка и фильтрация данных в MS Excel
    Понятие формализации. Часть 2.
    Загрузить файл
    Сделать бесплатный сайт с uCoz